Streams can stall when in a multipeer session.
Incident Report for CoScreen System Status Page
Resolved
8x8.vc has been updated, stream quality test looks good, everything is back to normal.
Posted Dec 14, 2021 - 20:53 PST
Monitoring
We have resolved the stream degradation issue by moving to our regional infrastructure temporarily.

We are actively monitoring for a fix from our service provider (8x8.vc).
Posted Dec 03, 2021 - 12:55 PST
Investigating
We are currently investigating a degradation of performance due to some changes from our video provider, 8x8.vc, that can cause screen shares to become stalled when going to low-bandwidth/bitrate or high packet loss environments.
Posted Dec 03, 2021 - 08:38 PST
This incident affected: CoScreen Client Application and CoScreen Infrastructure.