Login issues
Incident Report for CoScreen System Status Page
Resolved
Google reports that the incident is resolved. User logins should continue working normally.
Posted Mar 05, 2024 - 09:53 PST
Monitoring
We are seeing global reports of login issues with Google, which manages the CoScreen login experience. Some customers may be unable to log in.

If possible, users are advised not to log out until the disruption is resolved.

We will continue monitoring the situation and provide updates as the situation changes.
Posted Mar 05, 2024 - 08:26 PST
This incident affected: CoScreen Client Application.